Portals & uButler App Unavailable
Resolved
Nov 18 at 04:16pm CET
We’re back! Relocation Management Portal & Employee Web App are up and running. Thanks for bearing with us.
Affected services
Updated
Nov 18 at 02:26pm CET
We’re back! The uButler mobile application is up and running. Thanks for bearing with us, we'll provide another update about the remaining systems.
Affected services
Updated
Nov 18 at 01:08pm CET
We have identified the root cause of the issue and we are working on a resolution to bring our systems back online. We will update you shortly. Thank you for your patience!
Affected services
Created
Nov 18 at 12:30pm CET
We’re investigating an issue with an external outage (Cloudflare) that is impacting our core systems. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Affected services